Support Center

System Requirements for Apple iOS devices

Last Updated: Nov 27, 2017 09:53AM SGT
It’s easy to get HOOQ’d up using Apple iOS devices (iPad/iPhone/iPod Touch). Just make sure that your device meets the system requirements listed below, and you’ll be able to download the HOOQ app via the App Store. :)
  • Operating system (OS): iOS version 9.0 or higher. 
    • Don’t know your iOS version? You’ll find out how to check it when you click here.
    • Your iOS version does not meet the requirement? Click here for steps on how you can upgrade your iOS version.
  • Your iTunes account should be set to local. Click here for the how to.
Recommended internet speed:
  • At least 2-3 Mbps for smooth streaming.
  • At least 3G if you’re using a mobile data connection. 

Download the HOOQ app now for endless entertainment via your Apple (iOS) device! 

Have additional questions? Send us an email at or click this link!
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found